<!DOCTYPE html>
<!--[if lt IE 7]>      <html class="no-js lt-ie9 lt-ie8 lt-ie7"> <![endif]-->
<!--[if IE 7]>         <html class="no-js lt-ie9 lt-ie8"> <![endif]-->
<!--[if IE 8]>         <html class="no-js lt-ie9"> <![endif]-->
<!--[if gt IE 8]><!--> <html class="no-js"> <!--<![endif]-->
    <head>
				<link href='https://fonts.googleapis.com/css?family=Lora:400,400italic,700,700italic|Lato:400,700,900,400italic,700italic,900italic' rel='stylesheet' type='text/css'>
        <meta charset="utf-8">
        <meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">
				<title>FAITH: Praises for His blessings and provision - Orange Leader | Orange Leader</title>

								<script type="text/javascript">
					<!--
					if (screen.availWidth && screen.availWidth < 481) {
							//Conditional script here
              window.location.href = "https://" + "m.orangeleader.com" + window.location.pathname 
					}
					//-->
				</script>

        <!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GOOGLE_TAG_MANAGER_ID');</script>
<!-- End Google Tag Manager -->

								<link rel="stylesheet" type="text/css" media="screen" href="https://www.orangeleader.com/wp-content/themes/2016-bni/media/js/vendor/jquery.bxslider/jquery.bxslider.css?1600317682" />
				<link rel="stylesheet" href="https://www.orangeleader.com/wp-content/themes/2016-bni/media/css/normalize.css?1600317681" />
				<link rel="stylesheet" href="https://www.orangeleader.com/wp-content/themes/2016-bni/media/css/base.css?1600317681" />
				<link rel="stylesheet" type="text/css" media="screen" href="https://www.orangeleader.com/wp-content/themes/2016-bni/style.css?1600317682" />

        <script src="https://www.orangeleader.com/wp-content/themes/2016-bni/media/js/vendor/modernizr-2.6.2.min.js?1600317682"></script>

				<link rel="Shortcut Icon" type="image/ico" href="https://www.orangeleader.com/wp-content/themes/2016-orange-child/media/img/brand/favicon-orangeleader.png">

				
																
<!-- This site is optimized with the Yoast SEO plugin v12.1 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="canonical" href="https://www.orangeleader.com/2020/10/18/faith-praises-for-his-blessings-and-provision/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="FAITH: Praises for His blessings and provision - Orange Leader" />
<meta property="og:description" content="1 May God be gracious to us and bless us and make his face shine upon us, 2 that your ways may be known on earth, your salvation among all nations. 3 May the peoples praise you, O God; may all the peoples praise you. 4 May the nations be glad and sing for joy, &hellip;" />
<meta property="og:url" content="https://www.orangeleader.com/2020/10/18/faith-praises-for-his-blessings-and-provision/" />
<meta property="og:site_name" content="Orange Leader" />
<meta property="article:section" content="Lifestyle" />
<meta property="article:published_time" content="2020-10-18T05:21:12-05:00" />
<meta property="article:modified_time" content="2020-10-16T21:23:02-05:00" />
<meta property="og:updated_time" content="2020-10-16T21:23:02-05:00" />
<meta property="og:image" content="https://www.orangeleader.com/wp-content/uploads/sites/42/2019/11/Orange-First-Church-of-the-Nazarene.png" />
<meta property="og:image:secure_url" content="https://www.orangeleader.com/wp-content/uploads/sites/42/2019/11/Orange-First-Church-of-the-Nazarene.png" />
<meta property="og:image:width" content="543" />
<meta property="og:image:height" content="543" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="1 May God be gracious to us and bless us and make his face shine upon us, 2 that your ways may be known on earth, your salvation among all nations. 3 May the peoples praise you, O God; may all the peoples praise you. 4 May the nations be glad and sing for joy, [&hellip;]" />
<meta name="twitter:title" content="FAITH: Praises for His blessings and provision - Orange Leader" />
<meta name="twitter:image" content="https://www.orangeleader.com/wp-content/uploads/sites/42/2019/11/Orange-First-Church-of-the-Nazarene.png" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.orangeleader.com/#website","url":"https://www.orangeleader.com/","name":"Orange Leader","potentialAction":{"@type":"SearchAction","target":"https://www.orangeleader.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://www.orangeleader.com/2020/10/18/faith-praises-for-his-blessings-and-provision/#primaryimage","url":"https://www.orangeleader.com/wp-content/uploads/sites/42/2019/11/Orange-First-Church-of-the-Nazarene.png","width":543,"height":543,"caption":"Orange Naz"},{"@type":"WebPage","@id":"https://www.orangeleader.com/2020/10/18/faith-praises-for-his-blessings-and-provision/#webpage","url":"https://www.orangeleader.com/2020/10/18/faith-praises-for-his-blessings-and-provision/","inLanguage":"en-US","name":"FAITH: Praises for His blessings and provision - Orange Leader","isPartOf":{"@id":"https://www.orangeleader.com/#website"},"primaryImageOfPage":{"@id":"https://www.orangeleader.com/2020/10/18/faith-praises-for-his-blessings-and-provision/#primaryimage"},"datePublished":"2020-10-18T05:21:12-05:00","dateModified":"2020-10-16T21:23:02-05:00","author":{"@id":"https://www.orangeleader.com/#/schema/person/d6917ca8f4982c871dfd982169cd0c79"}},{"@type":["Person"],"@id":"https://www.orangeleader.com/#/schema/person/d6917ca8f4982c871dfd982169cd0c79","name":"Dawn Burleigh","image":{"@type":"ImageObject","@id":"https://www.orangeleader.com/#authorlogo","url":"https://secure.gravatar.com/avatar/98b6da4db525473481787df27b252bb9?s=96&d=mm&r=g","caption":"Dawn Burleigh"},"sameAs":[]}]}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Orange Leader &raquo; FAITH: Praises for His blessings and provision Comments Feed" href="https://www.orangeleader.com/2020/10/18/faith-praises-for-his-blessings-and-provision/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.orangeleader.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.4.2"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='all-css-0' href='https://www.orangeleader.com/_static/??-eJx9Ue1uwyAMfKEBSaVl249pzwKEJG75Ejbq+vZzknZqFSV/EPiO852trllAtL72DpVFVL3GCWyKKANEyZU39Uw5oyLGLyb9/l+2rEUIkJTxyV6EB1N0uSmkm3cvutyIXCSVfR0hogqOSoqORC5pAO9EBku1uCc1lKuMqeD7faGW28DVaZpcESaCkI08SbNYe5QPcs403TMkjC6HlrmUk/eollMwbZeKEDJnQtLDwEPhRLkaD3bptgHFCu43hn7kSaVMwDGURnS0Gn9FNgKcPXDEU9N282TuazlipaLj6ISdeOQ79FDFw9jZUda89i/ZLHbu7/nLT/huu6Z9/zx1zccf4XHrQw==' type='text/css' media='all' />
<style id='wp-block-library-inline-css'>
.has-text-align-justify{text-align:justify;}
</style>
<style id='admin-bar-inline-css'>
#wp-admin-bar-my-sites-search.hide-if-no-js {
	display: none;
}
#wp-admin-bar-my-sites-search label[for="my-sites-search-text"] {
	clip: rect(1px, 1px, 1px, 1px);
	position: absolute !important;
	height: 1px;
	width: 1px;
	overflow: hidden;
}
#wp-admin-bar-my-sites-search {
	height: 38px;
}
#wp-admin-bar-my-sites-search .ab-item {
	height: 34px;
}
#wp-admin-bar-my-sites-search input {
	padding: 0 2px;
	width: 95%;
	width: calc( 100% - 4px );
}
	
</style>
<style id='wp-polls-inline-css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 6px;
	line-height: 8px;
	height: 8px;
	background-image: url('https://www.orangeleader.com/wp-content/plugins/wp-polls/images/default/pollbg.gif');
	border: 1px solid #c8c8c8;
}

</style>
<script src='https://www.orangeleader.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script>
jQuery(document).ready( function($) {
	$('#wp-admin-bar-my-sites-search.hide-if-no-js').show();
	$('#wp-admin-bar-my-sites-search input').keyup( function( ) {

		var searchValRegex = new RegExp( $(this).val(), 'i');

		$('#wp-admin-bar-my-sites-list > li.menupop').hide().filter(function() {

			return searchValRegex.test( $(this).find('> a').text() );

		}).show();

	});
});
	
</script>
<script type='text/javascript' src='https://www.orangeleader.com/wp-includes/js/jquery/jquery-migrate.min.js?m=1591831626g'></script>
<link rel='https://api.w.org/' href='https://www.orangeleader.com/wp-json/' />
<link rel='shortlink' href='https://www.orangeleader.com/?p=65963' />
<link rel="alternate" type="application/json+oembed" href="https://www.orangeleader.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.orangeleader.com%2F2020%2F10%2F18%2Ffaith-praises-for-his-blessings-and-provision%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.orangeleader.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.orangeleader.com%2F2020%2F10%2F18%2Ffaith-praises-for-his-blessings-and-provision%2F&#038;format=xml" />
<link href="https://trinitymedia.ai" rel="preconnect" crossorigin="anonymous" />
<link href="https://vd.trinitymedia.ai" rel="preconnect" crossorigin="anonymous" />
<style type='text/css'>img#wpstats{display:none}</style><script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');
  ga('create', 'UA-63292741-1', 'auto');
  ga('send', 'pageview');
</script>
								<script type="text/javascript">
          var $ = jQuery;
          var adm_dmm_id = '5f7b46285c443b70829af427';
          var adm_dam_id = '5f7b465709d4330417988a04';
          var adm_dpm_id = '5f7b46415c443b70829af429';
          var loggedin = false;
          window.admiral = window.admiral || function() {(admiral.q = admiral.q || []).push(arguments)};

          function setCookie() {
              window.admiral('after','measure.detected',function(user) {
                  var d = new Date();
                  d.setTime(d.getTime() + (7*24*60*60*1000));
                  var n = d.toUTCString();
                  if (user.subscribed) {
                      document.cookie = "bni_admiral_loggedin=1; expires=" + n + "; path=/";
                      loggedin = true;
                      return;
                  }
                  document.cookie = "bni_admiral_loggedin=0; expires=" + n + "; path=/";
                  window.sessionStorage.setItem('cfS', '0');
              })
          }
          window.onload = setCookie();

          function readCookie(c) {
              var a = document.cookie.split(';');
              for (var i = 0; i < a.length; i++) {
                  var b = a[i].split('=');
                  var d = b[0].trim();
                  if (c === d) {
                      var e = b[1].trim();
                      if (e === "1") {
                          loggedin = true;
                      } else {
                          loggedin = false;
                      }
                  }
              }
              return true;
          }
          window.onload = readCookie('bni_admiral_loggedin');
          window.admiral('after', 'transact.subscribed', function() {
              var x = window.sessionStorage.getItem('cfS');
              if (x === "1") {
                  return;
              }
              window.sessionStorage.setItem('cfS', '1');
              location.reload();
          })

          $(window).load(function() { // These functions get called when everything has loaded
            if (!loggedin) {
              $("#supNav").append('<li><a href="#" onclick="window.admiral(&quot;show&quot;, &quot;transact.login&quot;,{offerID:&quot;' + adm_dmm_id + ',' + adm_dpm_id + ',' + adm_dam_id + '&quot;});">Log In</a></li>');
            } else {
              $("#supNav").append('<li><a href="#" onclick="window.admiral(&quot;show&quot;, &quot;transact.manage&quot;);">Manage Account</a></li>');
            }
            console.log('%c TESTING ADMIRAL V 2.1', 'background: #222; color: #bada55');
          });

          $( document ).ready(function() {
            // Digital Monthly Membership
            $('#adm_dmm').click(function(c) {
              c.preventDefault();
              window.admiral('show','transact.subscribe',{offerID:adm_dmm_id})
            });
            // Digital Annual Membership
            $('#adm_dam').click(function(c) {
              c.preventDefault();
              window.admiral('show','transact.subscribe',{offerID:adm_dam_id})
            });
            // Digital and Print Membership
            $('#adm_dpm').click(function(c) {
              c.preventDefault();
              window.admiral('show','transact.subscribe',{offerID:adm_dpm_id})
            });
          });
				</script>


				<script type="text/javascript" src="https://www.orangeleader.com/wp-content/themes/2016-bni/media/js/colorbox/jquery.colorbox-min.js"></script>
				<link rel="stylesheet" type="text/css" media="screen" href="https://www.orangeleader.com/wp-content/themes/2016-bni/media/js/colorbox/colorbox.css" />

        <script type="text/javascript">!(function(o,n,t){t=o.createElement(n),o=o.getElementsByTagName(n)[0],t.async=1,t.src="https://gondolagnome.com/v2/0/wgbTXS70ImFIIczPBXEI2s8DOHzc1bef6-WwBTf4KhW3g2UKrWuY0EGsN4QMaMSGqXf5-8IAN44pc8",o.parentNode.insertBefore(t,o)})(document,"script"),(function(o,n){o[n]=o[n]||function(){(o[n].q=o[n].q||[]).push(arguments)}})(window,"admiral");!(function(n,e,r,t){function o(){if((function o(t){try{return(t=localStorage.getItem("v4ac1eiZr0"))&&0<t.split(",")[4]}catch(n){}return!1})()){var t=n[e].pubads();typeof t.setTargeting===r&&t.setTargeting("admiral-engaged","true")}}(t=n[e]=n[e]||{}).cmd=t.cmd||[],typeof t.pubads===r?o():typeof t.cmd.unshift===r?t.cmd.unshift(o):t.cmd.push(o)})(window,"googletag","function");;;;;</script>

<script async src="https://sync.serverbid.com/ss/2000707.js"></script>


				
<script async src="//js-sec.indexww.com/ht/p/188239-192868292012837.js"></script>
<script id="optimera-ops" src="https://d15kdpgjg3unno.cloudfront.net/oPS.js?cid=57" data-cid="57"></script>


<!-- DFP Work -->

    <script src='https://www.googletagservices.com/tag/js/gpt.js'></script>


<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>


<script>

googletag.cmd.push(function() {

    			googletag.defineSlot('/1613683/ORN-160x600-1', [160, 600], 'div-gpt-ad-skyscraper').addService(googletag.pubads());
			googletag.defineSlot('/1613683/ORN-300x250-16', [300, 250], 'div-gpt-ad-instory-top').addService(googletag.pubads());
			googletag.defineSlot('/1613683/ORN-300x250-17', [300, 250], 'div-gpt-ad-instory-bottom').addService(googletag.pubads());
			googletag.defineSlot('/1613683/ORN-300x250-instory-third', [[300, 250], [1, 1]], 'div-gpt-ad-instory-third').addService(googletag.pubads());
			FEATUREDGALLERY_AD = googletag.defineSlot('/1613683/ORN-300x250-featured_gallery', [300, 250], 'div-gpt-ad-bigblock-featured_gallery').addService(googletag.pubads());

  if (!loggedin) {
			googletag.defineSlot('/1613683/ORN-1x1-2', [1,1], 'div-gpt-ad-extra_one_by_one').addService(googletag.pubads());
			googletag.defineSlot('/1613683/ORN-1x1-3', [1,1], 'div-gpt-ad-extra_oop').addService(googletag.pubads());
			googletag.defineSlot('/1613683/ORN-1x1-4', [1,1], 'div-gpt-ad-extra_one_by_one_two').addService(googletag.pubads());
  }

    			googletag.defineSlot('/1613683/ORN-300x100-1', [300, 100], 'div-gpt-ad-skybox').addService(googletag.pubads());
			googletag.defineSlot('/1613683/ORN-300x250-1', [[300, 600], [300, 250]], 'div-gpt-ad-bigblock-1').addService(googletag.pubads());
			googletag.defineSlot('/1613683/ORN-300x250-2', [[300, 600], [300, 250]], 'div-gpt-ad-bigblock-2').addService(googletag.pubads());
			googletag.defineSlot('/1613683/ORN-300x250-3', [[300, 600], [300, 250]], 'div-gpt-ad-bigblock-3').addService(googletag.pubads());

			googletag.defineSlot('/1613683/ORN-300x600-1', [[300, 600], [160, 600]], 'div-gpt-ad-halfpage-1').addService(googletag.pubads());
			googletag.defineSlot('/1613683/ORN-970x90-1', [[970, 90], [970, 250], [728, 90]], 'div-gpt-ad-largeleaderboard').addService(googletag.pubads());
			googletag.defineSlot('/1613683/ORN-1x1-duration', [1,1], 'div-gpt-ad-one_by_one_duration').addService(googletag.pubads());

  if (!loggedin) {
			googletag.defineSlot('/1613683/ORN-300x250-18', [300, 250], 'div-gpt-ad-bigblock-18').addService(googletag.pubads());
			googletag.defineSlot('/1613683/ORN-1x1-wall', [1,1], 'div-gpt-ad-one_by_one_wall').addService(googletag.pubads());
			googletag.defineOutOfPageSlot('/1613683/ORN-1x1-1', 'div-gpt-ad-screenshift').addService(googletag.pubads());
  }


                  googletag.pubads().setTargeting("catname", [ "faith-values", "lifestyle", "news", "orange",  ]);
                


          googletag.pubads().setTargeting("pageurl", "/2020/10/18/faith-praises-for-his-blessi");
    
      // TESTING 1.1
    // Lazy Load settings
    googletag.pubads().enableLazyLoad({
      fetchMarginPercent: 2,  // Fetch slots within .02 viewports.
      renderMarginPercent: 1,  // Render slots within .01 viewports.
      mobileScaling: 0  // same value on mobile.
    });
    
		googletag.pubads().enableSingleRequest();
		//googletag.pubads().collapseEmptyDivs()
    googletag.pubads().disableInitialLoad();
    googletag.enableServices();

});
</script>




<script>
//load the apstag.js library
!function(a9,a,p,s,t,A,g){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function(){q("f",arguments)},setDisplayBids:function(){},targetingKeys:function(){return[]},_Q:[]};A=p.createElement(s);A.async=!0;A.src=t;g=p.getElementsByTagName(s)[0];g.parentNode.insertBefore(A,g)}("apstag",window,document,"script","//c.amazon-adsystem.com/aax2/apstag.js");

//initialize the apstag.js library on the page to allow bidding
apstag.init({
     pubID:  '26673ab7-6c90-4748-8b4c-71512dcf8ef3', //enter your pub ID here as shown above, it must within quotes
     adServer: 'googletag'
});
apstag.fetchBids({
     slots: [{
          slotID: 'div-gpt-ad-skyscraper',
          slotName: '1613683/ORN-160x600-1',
          sizes: [[160, 600]]
      },
      //{
          //slotID: 'div-gpt-ad-skybox',
          //slotName: '1613683/ORN-300x100-1',
          //sizes: [[300, 100]]
      //},
      //{
          //slotID: 'div-gpt-ad-threesix-1',
          //slotName: '1613683/ORN-300x600-1',
          //sizes: [[300, 600]]
      //},
      {
          slotID: 'div-gpt-ad-bigblock-1',
          slotName: '1613683/ORN-300x250-1',
          sizes: [[300, 600], [300, 250]]
      },
      {
          slotID: 'div-gpt-ad-bigblock-2',
          slotName: '1613683/ORN-300x250-2',
          sizes: [[300, 600], [300, 250]]
      },
			{
					slotID: 'div-gpt-ad-bigblock-3',
					slotName: '1613683/ORN-300x250-3',
					sizes: [[300, 600], [300, 250]]
			},
      {
          slotID: 'div-gpt-ad-bigblock-4',
          slotName: '1613683/ORN-300x250-4',
          sizes: [[300, 250]]
      },
      {
          slotID: 'div-gpt-ad-bigblock-5',
          slotName: '1613683/ORN-300x250-5',
          sizes: [[300, 250]]
      },
			{
					slotID: 'div-gpt-ad-bigblock-6',
					slotName: '1613683/ORN-300x250-6',
					sizes: [[300, 250]]
			},
			{
					slotID: 'div-gpt-ad-bigblock-7',
					slotName: '1613683/ORN-300x250-7',
					sizes: [[300, 250]]
			},
			{
					slotID: 'div-gpt-ad-bigblock-8',
					slotName: '1613683/ORN-300x250-8',
					sizes: [[300, 250]]
			},
			{
					slotID: 'div-gpt-ad-bigblock-9',
					slotName: '1613683/ORN-300x250-9',
					sizes: [[300, 250]]
			},
			{
					slotID: 'div-gpt-ad-bigblock-10',
					slotName: '1613683/ORN-300x250-10',
					sizes: [[300, 250]]
			},
			{
					slotID: 'div-gpt-ad-bigblock-11',
					slotName: '1613683/ORN-300x250-11',
					sizes: [[300, 250]]
			},
			{
					slotID: 'div-gpt-ad-bigblock-12',
					slotName: '1613683/ORN-300x250-12',
					sizes: [[300, 250]]
			},
			{
					slotID: 'div-gpt-ad-bigblock-13',
					slotName: '1613683/ORN-300x250-13',
					sizes: [[300, 250]]
			},
			{
					slotID: 'div-gpt-ad-bigblock-14',
					slotName: '1613683/ORN-300x250-14',
					sizes: [[300, 250]]
			},
			{
					slotID: 'div-gpt-ad-bigblock-15',
					slotName: '1613683/ORN-300x250-15',
					sizes: [[300, 250]]
			},
      {
          slotID: 'div-gpt-ad-instory-top',
          slotName: '1613683/ORN-300x250-16',
          sizes: [[300, 250]]
      },
      {
          slotID: 'div-gpt-ad-instory-bottom',
          slotName: '1613683/ORN-300x250-17',
          sizes: [[300, 250]]
      },
      //{
          //slotID: 'div-gpt-ad-bigblock-18',
          //slotName: '1613683/ORN-300x250-18',
          //sizes: [[300, 250]]
      //},
      //{
          //slotID: 'div-gpt-ad-instory-third',
          //slotName: '1613683/ORN-300x250-instory-third',
          //sizes: [[300, 250]]
      //},
      {
          slotID: 'div-gpt-ad-mobile-sticky',
          slotName: '1613683/ORN-320x50-1',
          sizes: [[320, 50], [1, 1]]
      },
      {
          slotID: 'div-gpt-ad-largeleaderboard',
          slotName: '1613683/ORN-970x90-1',
          sizes: [[970, 90], [728, 90], [970, 250]]
     }],
     timeout: 2e3
}, function(bids) {
     // set apstag targeting on googletag, then trigger the first DFP request in googletag's disableInitialLoad integration
     googletag.cmd.push(function(){
         apstag.setDisplayBids();
				 googletag.pubads().refresh();
     });
}); 
</script>


<script>
   var otkjs = otkjs || {};
    /**
     * Add any divs to refresh.
     * 
     * Parameters:
     * 1. Array of divs w/parameter to refresh, can be one or many:
     *  - DIV_ID: The DOM div id of the ad position
     *  - MIN_TIME_IN_VIEW: The amount of time the ad must be 
     *      in view before being eligible to be refreshed, we recommend at least 1.1 seconds
     *  - MIN_TIME_ON_PAGE: The amount of time the ad must be in von the page before refreshing 
     *  - TARGETING: Array of key/value targeting for the ad slot.
     * 
     * NOTE: The ad will on refresh once the parameters are met and the ad is
     * is currently in view.
     * 
     * Function:
     * otkjs.addRefresh(
     * Array[
     *    Array[DIV_ID, MIN_TIME_IN_VIEW, MIN_TIME_ON_PAGE, TARGETING[Array['key', 'value']]
     * ]);
     * 
     * Example - add two ad divs to be refreshed:
     *   otkjs.addRefresh([
     *     ['div-1', 1.1, 30, [['key2', 'value2'], ['refresh', 'true']]],
     *     ['div-2', 1.1, 30, [['key4', 'value4'], ['refresh', 'true']]]
     *   ]);
     */
      var mt_in_view = 1.2
      var mt_on_page = 34

      otkjs.addRefresh([
        //['div-1', mt_in_view, mt_on_page, [['refresh', 'true']]]
            ['div-gpt-ad-skyscraper', mt_in_view, mt_on_page, [['refresh', 'true']]],
        ['div-gpt-ad-instory-top', mt_in_view, mt_on_page, [['refresh', 'true']]],
        ['div-gpt-ad-instory-bottom', mt_in_view, mt_on_page, [['refresh', 'true']]],
        ['div-gpt-ad-instory-third', mt_in_view, mt_on_page, [['refresh', 'true']]],
        ['div-gpt-ad-extra_one_by_one', mt_in_view, mt_on_page, [['refresh', 'true']]],
        ['div-gpt-ad-extra_oop', mt_in_view, mt_on_page, [['refresh', 'true']]],
        ['div-gpt-ad-extra_one_by_one_two', mt_in_view, mt_on_page, [['refresh', 'true']]],
            ['div-gpt-ad-skybox', mt_in_view, mt_on_page, [['refresh', 'true']]],
        ['div-gpt-ad-bigblock-1', mt_in_view, mt_on_page, [['refresh', 'true']]],
        ['div-gpt-ad-bigblock-2', mt_in_view, mt_on_page, [['refresh', 'true']]],
        ['div-gpt-ad-bigblock-3', mt_in_view, mt_on_page, [['refresh', 'true']]],
        ['div-gpt-ad-halfpage-1', mt_in_view, mt_on_page, [['refresh', 'true']]],
        ['div-gpt-ad-largeleaderboard', mt_in_view, mt_on_page, [['refresh', 'true']]],
        ['div-gpt-ad-one_by_one_wall', mt_in_view, mt_on_page, [['refresh', 'true']]],
        ['div-gpt-ad-screenshift', mt_in_view, mt_on_page, [['refresh', 'true']]]
      ]);
  </script>

                        <script type="text/javascript" src="//s.ntv.io/serve/load.js" async></script>
        

    </head>
		<body id="articlePage">
        <!--[if lt IE 7]>
            <p class="chromeframe">You are using an <strong>outdated</strong> browser. Please <a href="http://browsehappy.com/">upgrade your browser</a> or <a href="http://www.google.com/chromeframe/?redirect=true">activate Google Chrome Frame</a> to improve your experience.</p>
        <![endif]-->
        <!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GOOGLE_TAG_MANAGER_ID"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->
																<!-- Paste this after your <body> tag. Fill in "ARTICLE_URL" and "CONTENT_ID" --> 
				<script type="text/javascript"> 
				(function() { 
					var ARTICLE_URL = 'https://www.orangeleader.com/2020/10/18/faith-praises-for-his-blessings-and-provision/'; 
					var CONTENT_ID = ''; // Optional or leave empty 
					document.write( 
						'<scr'+'ipt '+ 
						'src="//survey.g.doubleclick.net/survey?site=_n7bb4n66jk54fvtjyvmqgenemq'+ 
						'&amp;url='+encodeURIComponent(ARTICLE_URL)+ 
						(CONTENT_ID ? '&amp;cid='+encodeURIComponent(CONTENT_ID) : '')+ 
						'&amp;random='+(new Date).getTime()+ 
						'" type="text/javascript">'+'\x3C/scr'+'ipt>'); 
          })(); 

          jQuery(document).ready(function() { // These functions get called on DOM ready
						if (!loggedin) {
							load_402_show_function();
						}
          });
				</script> 
				

				<div id="" class="undertone">


					<!-- Add your site or application content here -->

          <div id="sup_nav" class="sup_nav">

						<div class="ad large_leaderboard">
							<div class="ad970x90 large_leaderboard"><!-- ROS_970x90 -->
<div id='div-gpt-ad-largeleaderboard'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-largeleaderboard'); });
  </script>
</div></div>
						</div>

						<div class="wrapper">
							<ul id="supNav">
	<li class=""><a href="https://www.orangeleader.com/about-us">About Us</a></li>
	<li class="">
		<a href="https://www.orangeleader.com/submit/">Submit</a>
		<ul class="sub-nav">
			<li><a href="https://www.orangeleader.com/services/submit-a-news-tip/">Submit a news tip</a></li>		
			<li><a href="https://www.orangeleader.com/services/submit-a-classified-advertisement/">Submit a Classified Ad</a></li>		
		</ul>
	</li>
</ul>							<p class="date">
								October 18, 2020							</p>
							<div class="clearfix"></div>
						</div>
					</div>
					<div id="main_body" class="wrapper">

							
            						<header id="main_header">
							<div id="search_weather">
								<div id="weather">
									<div class="details">
										<ul>
											<li id="m1_miniweather_widget-2" class="widget widget_m1_miniweather_widget"><h2 class="widgettitle"></h2>
<div class="wi wi-owm-800" title="clear sky" style="font-size: 2em;">
			       <span class="m1mw_temp">70&deg;</span>
			     </div></li>
										</ul>
																				</div>
									<div class="clearfix"></div>
								</div>
								<div class="ad sponsorship">
										<!-- ROS_300x100_Skybox_Teaser -->
<div id='div-gpt-ad-skybox' style='height:100px; width:300px;'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-skybox'); });
  </script>
</div>								</div>
							</div>
            							<div id="logo">
								<a href="https://www.orangeleader.com">
									<img src="https://www.orangeleader.com/wp-content/themes/2016-orange-child/media/img/brand/logo-orangeleader.png" alt="Orange Leader" />
								</a>
							</div>
							<div class="clearfix"></div>
							<nav id="navbar">
								<a href="https://www.orangeleader.com">
									<img class="logo" class="logo" src="https://www.orangeleader.com/wp-content/themes/2016-orange-child/media/img/brand/logo-orangeleader.png" alt="Orange Leader" />
								</a>
								<ul id="mainNav">
	<li class="home "><a href="https://www.orangeleader.com">Home</a></li>
	<li class="news "><a href="https://www.orangeleader.com/category/news/">News</a>
			</li>
	<li class="sports"><a href="https://www.orangeleader.com/category/sports/">Sports</a>
			</li>
	<li class="opinion"><a href="https://www.orangeleader.com/category/opinion/">Opinion</a>
			</li>
			<li class="news "><a href="https://www.orangeleader.com/category/obituaries/">Obits</a></li>
	<li class="e-edition"><a href="https://subscriptions.orangeleader.com/CircStore/Account/Login?vendor=DirXion&prodId=OL">E-Edition</a></li>
	<li class="classifieds"><a href="https://marketplace.orangeleader.com/adhunter/orangecounty">Classifieds</a></li>
	<li class="subscribe"><a href="https://www.orangeleader.com/subscriptions/"><span>Subscribe</span></a></li>
	<li class="texas-press"><a href="https://www.orangeleader.com/tpa-press-releases/">Texas Press</a></li>



	<li>
								<div class="search">
									<form method="get" class="searchForm" action="https://www.orangeleader.com/site-search">
										<input type="submit" class="searchButton" value="Go" />
										<input type="text" name="q" class="searchQuery" value="Search Orange Leader..." onfocus="if(this.value=='Search Orange Leader...'){this.value='';}" onblur="if(this.value==''){this.value='Search Orange Leader...';}" />
									</form>
								</div>
	</li>

</ul>
							</nav>
							<div class="clearfix"></div>
						</header>

						<div id="content" class="">
							<div id="notifications">
																
																							</div>


<div class="one_by_one_group">
<!-- one_by_one_wall-->
<div id='div-gpt-ad-one_by_one_wall'>
<script type='text/javascript'>
jQuery(window).load(function() { // These functions get called when everything has loaded
	if (!loggedin) {
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-one_by_one_wall'); });
  }
});
</script>
</div></div>

	


							<div class="main_column">
								<div class="story">
									
									
                    <div class="gallery_group">
      <div id="story_photo_group">
        
                                    <dl class='story_photo_item'><dt><img width="543" height="543" src="https://www.orangeleader.com/wp-content/uploads/sites/42/2019/11/Orange-First-Church-of-the-Nazarene.png?w=543" class="attachment-story-photo size-story-photo wp-post-image" alt="Orange Naz" srcset="https://www.orangeleader.com/wp-content/uploads/sites/42/2019/11/Orange-First-Church-of-the-Nazarene.png 543w, https://www.orangeleader.com/wp-content/uploads/sites/42/2019/11/Orange-First-Church-of-the-Nazarene.png?resize=150,150 150w, https://www.orangeleader.com/wp-content/uploads/sites/42/2019/11/Orange-First-Church-of-the-Nazarene.png?resize=300,300 300w, https://www.orangeleader.com/wp-content/uploads/sites/42/2019/11/Orange-First-Church-of-the-Nazarene.png?resize=350,350 350w, https://www.orangeleader.com/wp-content/uploads/sites/42/2019/11/Orange-First-Church-of-the-Nazarene.png?resize=90,90 90w, https://www.orangeleader.com/wp-content/uploads/sites/42/2019/11/Orange-First-Church-of-the-Nazarene.png?resize=45,45 45w, https://www.orangeleader.com/wp-content/uploads/sites/42/2019/11/Orange-First-Church-of-the-Nazarene.png?resize=24,24 24w, https://www.orangeleader.com/wp-content/uploads/sites/42/2019/11/Orange-First-Church-of-the-Nazarene.png?resize=48,48 48w, https://www.orangeleader.com/wp-content/uploads/sites/42/2019/11/Orange-First-Church-of-the-Nazarene.png?resize=96,96 96w" sizes="(max-width: 543px) 100vw, 543px" /></dt><dd class='wp-caption-text'></dd></dl>

              </div>
    </div>

		
									<div id="leftRail" class="">
										<ul class="sidebar">
																																</ul>

										<div class="ad">
												<!-- ROS_160x600_Sidebar -->
<div id='div-gpt-ad-skyscraper'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-skyscraper'); });
  </script>
</div>										</div>
									</div><!-- END LEFTRAIL -->

									<div id="article">

										<h2>FAITH: Praises for His blessings and provision</h2>

										<div class="byline">
											
											<a href="https://www.orangeleader.com/author/Dawn.Burleigh/" rel="bookmark">
                        <img alt='' src='https://secure.gravatar.com/avatar/98b6da4db525473481787df27b252bb9?s=120&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/98b6da4db525473481787df27b252bb9?s=240&#038;d=mm&#038;r=g 2x' class='avatar avatar-120 photo' height='120' width='120' />											</a>

											<p class="author">
                        <strong>By <a href="https://www.orangeleader.com/author/dawn-burleigh/" rel="bookmark">Dawn Burleigh</a></strong>
																							</p>
											<p class="social">
												<a class="email" href="mailto:dawn.burleigh@orangeleader.com">Email the author</a>
																								 | 
													<a href="https://twitter.com/@DawnBurleigh" target="_blank">twitter</a>
																							</p>
											<p class="pubStamp">Published 12:21 am Sunday, October 18, 2020</p>
																						<div class="clearfix"></div>
										</div><!-- END BYLINE -->

                    
                    <div class="one_by_one_group">
											<!-- extra_one_by_one -->
<div id='div-gpt-ad-extra_one_by_one'>
<script type='text/javascript'>
jQuery(window).load(function() { // These functions get called when everything has loaded
	if (!loggedin) {
    //console.log('========== BNI v10b not logged in ==========');
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-extra_one_by_one'); });
  } else { 
    //console.log('========== BNI v10b logged in ==========');
  }
});
</script>
</div>											<!-- extra_one_by_one_two -->
<div id='div-gpt-ad-extra_one_by_one_two'>
<script type='text/javascript'>
jQuery(window).load(function() { // These functions get called when everything has loaded
	if (!loggedin) {
    //console.log('========== BNI v10b not logged in ==========');
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-extra_one_by_one_two'); });
  } else { 
    //console.log('========== BNI v10b logged in ==========');
  }
});
  </script>
</div>											<!-- extra_oop -->
<div id='div-gpt-ad-extra_oop'>
<script type='text/javascript'>
jQuery(window).load(function() { // These functions get called when everything has loaded
	if (!loggedin) {
    //console.log('========== BNI v10b not logged in ==========');
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-extra_oop'); });
  } else { 
    //console.log('========== BNI v10b logged in ==========');
  }
});
</script>
</div>                    </div>

										<div class="p402_premium">

										
										<div class="story_detail">
											
        <table id="trinity-audio-table" style="width:100%; display: table;">
            <tr>
                <td id="trinity-audio-tab" style="border: none;">
                    <div id="trinity-audio-player-label"></div>
                    <script>var TRINITY_TTS_WP_CONFIG = {"cleanText":"FAITH: Praises for His blessings and provision. \r\n\r\n1 May God be gracious to us and bless us and make his face shine upon us, 2 that your ways may be known on earth, your salvation among all nations. 3 May the peoples praise you, O God; may all the peoples praise you. 4 May the nations be glad and sing for joy, for you rule the peoples justly and guide the nations of the earth. 5 May the peoples praise you, O God; may all the peoples praise you. 6 Then the land will yield its harvest, and God, our God, will bless us. 7 God will bless us, and all the ends of the earth will fear him. - Psalm 67\r\n\r\n\u00a0I am currently preaching through a message series called, \u201cThe Blessed Life!\u201d\u00a0 It has become evident to me yet again, that the blessed life is about the condition of our heart.\u00a0 Obviously, I am not talking about our physical heart, though we know our culture continues to face a crisis of physical heart health, but of the place inside each of us where life is managed and where we are led.\u00a0 The condition of our life\u2019s central command center is the platform for the Lord to lavish us with His blessings! Does my heart belong fully to God?\u00a0 Is my life in a place where the Lord can bless me?\u00a0 These are important questions we must be willing to continually ask ourselves if we desire to live in the blessings of God.\r\n\r\nWhat I want all of you to hear is the Lord desires greatly to bless HIS people!\u00a0 The key word here is HIS!\u00a0 I cannot say the Lord does not bless people who do not follow Him, I cannot speak for the Lord.\u00a0 As well, we know the Lord is gracious, merciful, and kind, so I have an assumption He blesses all people in some form or another.\u00a0 The quest however is the blessed LIFE.\u00a0 A complete life of blessings is only possible for those who are living for God and continually yield their heart to HIM!\r\n\r\nWe also must consider how God blesses a nation.\u00a0 If God continually blesses the life of a person whose heart is devoted to God, then it seems to lend God blesses groups of people or even a nation filled with the hearts of folks yielded to Him!\u00a0 The criteria as well seems to be a nation intentionally making the ways of the Lord known and continually giving the Lord praise for His blessings and provision!\u00a0 I have continued to wonder during this year especially if our nation is still in a place in our heart towards God to be in line for His blessings.\r\n\r\nObviously, there are many in this nation who love the Lord, serve the Lord, and yield their hearts to Him.\u00a0 The concern I have is what looks like a dwindling number of people who are willing to be devoted to God and the increasing number of people who are committed to the selfish motives of humanism.\u00a0 By understanding the Word of God and the truth we find from the conviction of the Holy Spirit, it would make sense for our nation to be on the back end of God\u2019s gracious blessings we have been used to receiving.\u00a0 Can God still bless America?\u00a0 Will God still bless America?\u00a0 I want to believe yes to both questions, but it still comes back to our hearts.\u00a0 A broken heart and a contrite spirit will not be denied by the Lord.\u00a0 Are we willing to repent and yield to HIM?\r\n\r\nI would encourage you to ask these questions of yourself and your family and friends.\u00a0 It must start somewhere.\u00a0 I agree we are in such a shape of our civilization we are far from where the Lord would want us to be so He could continue to bless us.\u00a0 The error of our ways can be remedied, but we cannot continue to put it off.\u00a0 It can start with a remnant, and it starts on our knees broken and honest before the Lord.\u00a0 The Lord can and will heal the heart of a person and a nation willing to return to Him and walk in His ways.\r\n\r\nOur nation is in turmoil and we have gone our own way, but when we turn our hearts to the Lord, He will never turn us away!\r\n\r\nThat is Good News!\r\n\r\nRev. Brad McKenzie is Lead Pastor at Orange First Church of the Nazarene, 3810 Martin Luther King Jr. Drive in Orange.\u00a0 ","pluginVersion":"2.4.0"};</script><script type="text/javascript" src="https://trinitymedia.ai/player/trinity.php?viewkey=b627273bb1cb083235bd64e4dc874ca2&postHash=774de0cc45d43c270ca60842df8440e8&language=en-US&voiceGender=m&poweredby=1"></script>
                </td>
            </tr>
        </table><script>console.debug('TRINITY_WP', 'trinity_content_filter');</script><div id="attachment_50701" style="width: 310px" class="wp-caption alignnone"><a href="https://www.orangeleader.com/wp-content/uploads/sites/42/2019/08/Brad-McKenzie-e1566622234487.jpg"><img aria-describedby="caption-attachment-50701" class="size-medium wp-image-50701" src="https://www.orangeleader.com/wp-content/uploads/sites/42/2019/08/Brad-McKenzie-e1566622234487.jpg?w=300" alt="" width="300" height="292" srcset="https://www.orangeleader.com/wp-content/uploads/sites/42/2019/08/Brad-McKenzie-e1566622234487.jpg 2696w, https://www.orangeleader.com/wp-content/uploads/sites/42/2019/08/Brad-McKenzie-e1566622234487.jpg?resize=300,292 300w, https://www.orangeleader.com/wp-content/uploads/sites/42/2019/08/Brad-McKenzie-e1566622234487.jpg?resize=768,747 768w, https://www.orangeleader.com/wp-content/uploads/sites/42/2019/08/Brad-McKenzie-e1566622234487.jpg?resize=1024,996 1024w, https://www.orangeleader.com/wp-content/uploads/sites/42/2019/08/Brad-McKenzie-e1566622234487.jpg?resize=1536,1494 1536w, https://www.orangeleader.com/wp-content/uploads/sites/42/2019/08/Brad-McKenzie-e1566622234487.jpg?resize=2048,1993 2048w, https://www.orangeleader.com/wp-content/uploads/sites/42/2019/08/Brad-McKenzie-e1566622234487.jpg?resize=622,605 622w, https://www.orangeleader.com/wp-content/uploads/sites/42/2019/08/Brad-McKenzie-e1566622234487.jpg?resize=360,350 360w, https://www.orangeleader.com/wp-content/uploads/sites/42/2019/08/Brad-McKenzie-e1566622234487.jpg?resize=45,45 45w, https://www.orangeleader.com/wp-content/uploads/sites/42/2019/08/Brad-McKenzie-e1566622234487.jpg?resize=24,24 24w, https://www.orangeleader.com/wp-content/uploads/sites/42/2019/08/Brad-McKenzie-e1566622234487.jpg?resize=48,48 48w" sizes="(max-width: 300px) 100vw, 300px" /></a><p id="caption-attachment-50701" class="wp-caption-text">Brad McKenzie</p></div>
<p><em>1 May God be gracious to us and bless us and make his face shine upon us, 2 that your ways may be known on earth, your salvation among all nations. 3 May the peoples praise you, O God; may all the peoples praise you. 4 May the nations be glad and sing for joy, for you rule the peoples justly and guide the nations of the earth. 5 May the peoples praise you, O God; may all the peoples praise you. 6 Then the land will yield its harvest, and God, our God, will bless us. 7 God will bless us, and all the ends of the earth will fear him. &#8211; </em>Psalm 67</p>
<p><em> </em>I am currently preaching through a message series called, “The Blessed Life!”  It has become evident to me yet again, that the blessed life is about the condition of our heart.  Obviously, I am not talking about our physical heart, though we know our culture continues to face a crisis of physical heart health, but of the place inside each of us where life is managed and where we are led.  The condition of our life’s central command center is the platform for the Lord to lavish us with His blessings! Does my heart belong fully to God?  Is my life in a place where the Lord can bless me?  These are important questions we must be willing to continually ask ourselves if we desire to live in the blessings of God.</p>
<p>What I want all of you to hear is the Lord desires greatly to bless HIS people!  The key word here is HIS!  I cannot say the Lord does not bless people who do not follow Him, I cannot speak for the Lord.  As well, we know the Lord is gracious, merciful, and kind, so I have an assumption He blesses all people in some form or another.  The quest however is the blessed LIFE.  A complete life of blessings is only possible for those who are living for God and continually yield their heart to HIM!</p>
<div id='mydfpad' class='ad300x ad'><div id='div-gpt-ad-instory-top' style='width:300px; height:250px; clear:both;'>
                  <script type='text/javascript'>
                  googletag.cmd.push(function() { googletag.display('div-gpt-ad-instory-top'); });
                  </script>
                  </div>
                  </div>
                  <div id='cedato-unit'></div><p>We also must consider how God blesses a nation.  If God continually blesses the life of a person whose heart is devoted to God, then it seems to lend God blesses groups of people or even a nation filled with the hearts of folks yielded to Him!  The criteria as well seems to be a nation intentionally making the ways of the Lord known and continually giving the Lord praise for His blessings and provision!  I have continued to wonder during this year especially if our nation is still in a place in our heart towards God to be in line for His blessings.</p>
<p>Obviously, there are many in this nation who love the Lord, serve the Lord, and yield their hearts to Him.  The concern I have is what looks like a dwindling number of people who are willing to be devoted to God and the increasing number of people who are committed to the selfish motives of humanism.  By understanding the Word of God and the truth we find from the conviction of the Holy Spirit, it would make sense for our nation to be on the back end of God’s gracious blessings we have been used to receiving.  Can God still bless America?  Will God still bless America?  I want to believe yes to both questions, but it still comes back to our hearts.  A broken heart and a contrite spirit will not be denied by the Lord.  Are we willing to repent and yield to HIM?</p>
<p>I would encourage you to ask these questions of yourself and your family and friends.  It must start somewhere.  I agree we are in such a shape of our civilization we are far from where the Lord would want us to be so He could continue to bless us.  The error of our ways can be remedied, but we cannot continue to put it off.  It can start with a remnant, and it starts on our knees broken and honest before the Lord.  The Lord can and will heal the heart of a person and a nation willing to return to Him and walk in His ways.</p>
<div id='mydfpad3' class='ad'>
                  <div id='div-gpt-ad-instory-third'>
                  <script type='text/javascript'>
                  googletag.cmd.push(function() { googletag.display('div-gpt-ad-instory-third'); });
                  </script>
                  </div>
                  </div><p>Our nation is in turmoil and we have gone our own way, but when we turn our hearts to the Lord, He will never turn us away!</p>
<p>That is Good News!</p>
<div id='mydfpad2' class='ad300x ad'>
                  <div id='div-gpt-ad-instory-bottom' style='width:300px; height:250px; clear:both;'>
                  <script type='text/javascript'>
                  googletag.cmd.push(function() { googletag.display('div-gpt-ad-instory-bottom'); });
                  </script>
                  </div>
                  </div><p><em>Rev. Brad McKenzie is Lead Pastor at Orange First Church of the Nazarene, 3810 Martin Luther King Jr. Drive in Orange.  </em></p>

                                            



										</div><!-- END STORY_DETAIL -->
										</div><!-- END p402_premium (GOOGLE SURVEY) -->
										<script type="text/javascript">
											 var load_402_show_function = function () { try { _402_Show(); } catch(e) { } }
										</script>

                      <div class="prev_next_article">
  <!-- v 1.8 -->

                              <div class="next_article">
        <div class="padding">
          <div class="label">You Might Like</div>
                    <div class="thumb">
            <a href="https://www.orangeleader.com/2020/10/17/and-now-you-know-eighty-years-ago-in-orange-on-october-17-1940/">
              <img src="https://www.orangeleader.com/wp-content/uploads/sites/42/2019/11/Untitled.png?w=90&h=90&crop=1" alt="" width="50" height="50">
            </a>
          </div>
                    <h4> <a href="https://www.orangeleader.com/2020/10/17/and-now-you-know-eighty-years-ago-in-orange-on-october-17-1940/">And Now You Know: Eighty years ago in Orange on October 17, 1940</a></h4>
          <p>Mike LouviereAnd Now You Know The Orange Leader edition for October 17, 1940 reported on progress for the construction of... <a href="https://www.orangeleader.com/2020/10/17/and-now-you-know-eighty-years-ago-in-orange-on-october-17-1940/">read more</a></p>
        </div>
      </div>
        <div class="clearfix"></div>
  </div>


												
											<div class="print_this">
													<a href="#">Print Article</a>
											</div><!-- END print_this -->


											<div class="articleOptions">
												<div class="admin">
</div>
<div class="clearfix"></div>


											</div>


                      

<div class="rev_ad">
  <div id="rc-widget-61eef3" data-rc-widget data-widget-host="habitat" data-endpoint="//trends.revcontent.com" data-widget-id="134164"></div>
        <script type="text/javascript" src="https://assets.revcontent.com/master/delivery.js" defer="defer"></script>
  </div>
  

	
<div class="one_by_one_group">
<!-- one_by_one_duration-->
<div id='div-gpt-ad-one_by_one_duration'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-one_by_one_duration'); });
  </script>
</div><div id="rev_video"></div>
</div>



											

<div id="disqus_thread"></div>

<script>
    /**
    * RECOMMENDED CONFIGURATION VARIABLES: EDIT AND UNCOMMENT THE SECTION BELOW TO INSERT DYNAMIC VALUES FROM YOUR PLATFORM OR CMS.
    * LEARN WHY DEFINING THESE VARIABLES IS IMPORTANT: https://disqus.com/admin/universalcode/#configuration-variables
    */
    /*
    */
    var disqus_config = function () {
      //this.page.url = 'https://www.orangeleader.com/2020/10/18/faith-praises-for-his-blessings-and-provision/';
      this.page.identifier = '65963 https://www.orangeleader.com/?p=65963';
      this.page.title = 'FAITH: Praises for His blessings and provision - Orange Leader';
    };
    (function() { // DON'T EDIT BELOW THIS LINE
    var d = document, s = d.createElement('script');

    s.src = '//orangeleader.disqus.com/embed.js';

    s.setAttribute('data-timestamp', +new Date());
    (d.head || d.body).appendChild(s);
    })();
</script>
  <noscript>Please enable JavaScript to view the <a href="https://disqus.com/?ref_noscript" rel="nofollow">comments powered by Disqus.</a></noscript>


									</div>
									<div class="clearfix"></div>

								</div>
							</div>
							<div class="col last">
								
<ul class="sidebar">

	<li>
		<div class="ad first">
			<div id='div-gpt-ad-bigblock-1'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-bigblock-1'); });
  </script>
</div>		</div>
		<div class="ad ">
			<div id='div-gpt-ad-bigblock-18'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-bigblock-18'); });
  </script>
</div>		</div>


	</li>
	<style>.rpwe-block ul{
list-style: none !important;
margin-left: 0 !important;
padding-left: 0 !important;
}

.rpwe-block li{
border-bottom: 1px solid #eee;
margin-bottom: 10px;
padding-bottom: 10px;
list-style-type: none;
}

.rpwe-block a{
display: inline !important;
text-decoration: none;
}

.rpwe-block h3{
background: none !important;
clear: none;
margin-bottom: 0 !important;
margin-top: 0 !important;
font-weight: 400;
font-size: 12px !important;
line-height: 1.5em;
}

.rpwe-thumb{
border: 1px solid #eee !important;
box-shadow: none !important;
margin: 2px 10px 2px 0;
padding: 3px !important;
}

.rpwe-summary{
font-size: 12px;
}

.rpwe-time{
color: #bbb;
font-size: 11px;
}

.rpwe-comment{
color: #bbb;
font-size: 11px;
padding-left: 5px;
}

.rpwe-alignleft{
display: inline;
float: left;
}

.rpwe-alignright{
display: inline;
float: right;
}

.rpwe-aligncenter{
display: block;
margin-left: auto;
margin-right: auto;
}

.rpwe-clearfix:before,
.rpwe-clearfix:after{
content: "";
display: table !important;
}

.rpwe-clearfix:after{
clear: both;
}

.rpwe-clearfix{
zoom: 1;
}
</style><li id="rpwe_widget-2" class="widget rpwe_widget recent-posts-extended"><h2 class="widgettitle">Latest Obits</h2>
<div  class="rpwe-block "><ul class="rpwe-ul"><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://www.orangeleader.com/2020/10/16/death-notices-10-16-20/" title="Permalink to Death Notices 10.16.20" rel="bookmark">Death Notices 10.16.20</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://www.orangeleader.com/2020/10/15/death-notices-10-15-20/" title="Permalink to Death Notices 10.15.20" rel="bookmark">Death Notices 10.15.20</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://www.orangeleader.com/2020/10/13/death-notices-10-13-20/" title="Permalink to Death Notices 10.13.20" rel="bookmark">Death Notices 10.13.20</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://www.orangeleader.com/2020/10/13/lamar-andrews/" title="Permalink to Lamar Andrews" rel="bookmark">Lamar Andrews</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://www.orangeleader.com/2020/10/12/death-notices-10-11-12/" title="Permalink to Death Notices 10.11.12" rel="bookmark">Death Notices 10.11.12</a></h3></li></ul></div><!-- Generated by http://wordpress.org/plugins/recent-posts-widget-extended/ --></li>
<style>.rpwe-block ul{
list-style: none !important;
margin-left: 0 !important;
padding-left: 0 !important;
}

.rpwe-block li{
border-bottom: 1px solid #eee;
margin-bottom: 10px;
padding-bottom: 10px;
list-style-type: none;
}

.rpwe-block a{
display: inline !important;
text-decoration: none;
}

.rpwe-block h3{
background: none !important;
clear: none;
margin-bottom: 0 !important;
margin-top: 0 !important;
font-weight: 400;
font-size: 12px !important;
line-height: 1.5em;
}

.rpwe-thumb{
border: 1px solid #eee !important;
box-shadow: none !important;
margin: 2px 10px 2px 0;
padding: 3px !important;
}

.rpwe-summary{
font-size: 12px;
}

.rpwe-time{
color: #bbb;
font-size: 11px;
}

.rpwe-comment{
color: #bbb;
font-size: 11px;
padding-left: 5px;
}

.rpwe-alignleft{
display: inline;
float: left;
}

.rpwe-alignright{
display: inline;
float: right;
}

.rpwe-aligncenter{
display: block;
margin-left: auto;
margin-right: auto;
}

.rpwe-clearfix:before,
.rpwe-clearfix:after{
content: "";
display: table !important;
}

.rpwe-clearfix:after{
clear: both;
}

.rpwe-clearfix{
zoom: 1;
}
</style><li id="rpwe_widget-3" class="widget rpwe_widget recent-posts-extended"><h2 class="widgettitle">Latest Sports</h2>
<div  class="rpwe-block "><ul class="rpwe-ul"><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://www.orangeleader.com/2020/10/17/lumbertons-ends-lady-cardinal-win-streak-in-5/" title="Permalink to Lumberton ends Lady Cardinal win streak in 5" rel="bookmark">Lumberton ends Lady Cardinal win streak in 5</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://www.orangeleader.com/2020/10/16/silsbees-big-play-offense-powers-past-cardinals-51-21/" title="Permalink to Silsbee&#8217;s big-play offense powers past Cardinals, 51-21" rel="bookmark">Silsbee&#8217;s big-play offense powers past Cardinals, 51-21</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://www.orangeleader.com/2020/10/16/mustangs-gallop-past-bobcats-51-7/" title="Permalink to Mustangs gallop past Bobcats, 51-7" rel="bookmark">Mustangs gallop past Bobcats, 51-7</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://www.orangeleader.com/2020/10/16/pirates-ground-game-wears-down-bears-32-7/" title="Permalink to Pirates ground game wears down Bears, 32-7" rel="bookmark">Pirates ground game wears down Bears, 32-7</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://www.orangeleader.com/2020/10/15/mustangs-await-bobcats-in-11-4a-action/" title="Permalink to Mustangs await Bobcats in 11-4A action" rel="bookmark">Mustangs await Bobcats in 11-4A action</a></h3></li></ul></div><!-- Generated by http://wordpress.org/plugins/recent-posts-widget-extended/ --></li>
		<li>

		<div class="ad">
			<div id='div-gpt-ad-bigblock-2'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-bigblock-2'); });
  </script>
</div>		</div>
	</li>
	<style>
.rpwe-block ul{list-style:none!important;margin-left:0!important;padding-left:0!important;}.rpwe-block li{border-bottom:1px solid #eee;margin-bottom:10px;padding-bottom:10px;list-style-type: none;}.rpwe-block a{display:inline!important;text-decoration:none;}.rpwe-block h3{background:none!important;clear:none;margin-bottom:0!important;margin-top:0!important;font-weight:400;font-size:12px!important;line-height:1.5em;}.rpwe-thumb{border:1px solid #EEE!important;box-shadow:none!important;margin:2px 10px 2px 0;padding:3px!important;}.rpwe-summary{font-size:12px;}.rpwe-time{color:#bbb;font-size:11px;}.rpwe-comment{color:#bbb;font-size:11px;padding-left:5px;}.rpwe-alignleft{display:inline;float:left;}.rpwe-alignright{display:inline;float:right;}.rpwe-aligncenter{display:block;margin-left: auto;margin-right: auto;}.rpwe-clearfix:before,.rpwe-clearfix:after{content:"";display:table !important;}.rpwe-clearfix:after{clear:both;}.rpwe-clearfix{zoom:1;}
</style>
	<li id="rpwe_widget-4" class="widget rpwe_widget recent-posts-extended"><h2 class="widgettitle">Latest Opinion</h2>
<div  class="rpwe-block "><ul class="rpwe-ul"><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://www.orangeleader.com/2020/10/18/op-ed-even-during-a-pandemic-government-must-be-open-with-easy-access/" title="Permalink to OP-ED: Even during a pandemic, government must be open with easy access" rel="bookmark">OP-ED: Even during a pandemic, government must be open with easy access</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://www.orangeleader.com/2020/10/17/op-ed-newspapers-get-my-vote/" title="Permalink to OP-ED: Newspapers get my vote" rel="bookmark">OP-ED: Newspapers get my vote</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://www.orangeleader.com/2020/10/17/ltte-evergreen-cemetery-questions/" title="Permalink to LTTE: Evergreen Cemetery questions" rel="bookmark">LTTE: Evergreen Cemetery questions</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://www.orangeleader.com/2020/10/16/op-ed-story-over-a-cup-attack-of-the-killer-cabinets/" title="Permalink to OP-ED: Story Over a Cup &#8211;  Attack of the killer cabinets" rel="bookmark">OP-ED: Story Over a Cup &#8211;  Attack of the killer cabinets</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://www.orangeleader.com/2020/10/15/op-ed-celebrate-rights-by-voting-in-upcoming-election/" title="Permalink to OP-ED: Celebrate rights by voting in upcoming election" rel="bookmark">OP-ED: Celebrate rights by voting in upcoming election</a></h3></li></ul></div><!-- Generated by http://wordpress.org/plugins/recent-posts-widget-extended/ --></li>
<style>
.rpwe-block ul{list-style:none!important;margin-left:0!important;padding-left:0!important;}.rpwe-block li{border-bottom:1px solid #eee;margin-bottom:10px;padding-bottom:10px;list-style-type: none;}.rpwe-block a{display:inline!important;text-decoration:none;}.rpwe-block h3{background:none!important;clear:none;margin-bottom:0!important;margin-top:0!important;font-weight:400;font-size:12px!important;line-height:1.5em;}.rpwe-thumb{border:1px solid #EEE!important;box-shadow:none!important;margin:2px 10px 2px 0;padding:3px!important;}.rpwe-summary{font-size:12px;}.rpwe-time{color:#bbb;font-size:11px;}.rpwe-comment{color:#bbb;font-size:11px;padding-left:5px;}.rpwe-alignleft{display:inline;float:left;}.rpwe-alignright{display:inline;float:right;}.rpwe-aligncenter{display:block;margin-left: auto;margin-right: auto;}.rpwe-clearfix:before,.rpwe-clearfix:after{content:"";display:table !important;}.rpwe-clearfix:after{clear:both;}.rpwe-clearfix{zoom:1;}
</style>
	<li id="rpwe_widget-5" class="widget rpwe_widget recent-posts-extended"><h2 class="widgettitle">Crime</h2>
<div  class="rpwe-block "><ul class="rpwe-ul"><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://www.orangeleader.com/2020/10/16/assaults-gun-shots-keep-police-busy/" title="Permalink to Assaults, gun shots keep police busy" rel="bookmark">Assaults, gun shots keep police busy</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://www.orangeleader.com/2020/10/16/orange-police-beat-10-8-10-15-2/" title="Permalink to Orange Police Beat 10.8-10.15.2" rel="bookmark">Orange Police Beat 10.8-10.15.2</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://www.orangeleader.com/2020/10/16/doj-charges-more-than-14200-defendants-with-firearms-related-crimes-in-fy20/" title="Permalink to DOJ charges more than 14,200 defendants with firearms related crimes in FY20" rel="bookmark">DOJ charges more than 14,200 defendants with firearms related crimes in FY20</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://www.orangeleader.com/2020/10/16/man-arrested-for-possession-of-child-pornography/" title="Permalink to Man arrested for Possession of Child Pornography" rel="bookmark">Man arrested for Possession of Child Pornography</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://www.orangeleader.com/2020/10/15/twenty-four-defendants-including-alleged-aryan-circle-gang-members-and-associates-indicted-on-racketeering-firearms-and-drug-chrges-in-multiple-states/" title="Permalink to Twenty-Four Defendants, Including Alleged Aryan Circle Gang Members and Associates Indicted on Racketeering, Firearms, and Drug Chrges in Multiple States" rel="bookmark">Twenty-Four Defendants, Including Alleged Aryan Circle Gang Members and Associates Indicted on Racketeering, Firearms, and Drug Chrges in Multiple States</a></h3></li></ul></div><!-- Generated by http://wordpress.org/plugins/recent-posts-widget-extended/ --></li>
<style>
.rpwe-block ul{list-style:none!important;margin-left:0!important;padding-left:0!important;}.rpwe-block li{border-bottom:1px solid #eee;margin-bottom:10px;padding-bottom:10px;list-style-type: none;}.rpwe-block a{display:inline!important;text-decoration:none;}.rpwe-block h3{background:none!important;clear:none;margin-bottom:0!important;margin-top:0!important;font-weight:400;font-size:12px!important;line-height:1.5em;}.rpwe-thumb{border:1px solid #EEE!important;box-shadow:none!important;margin:2px 10px 2px 0;padding:3px!important;}.rpwe-summary{font-size:12px;}.rpwe-time{color:#bbb;font-size:11px;}.rpwe-comment{color:#bbb;font-size:11px;padding-left:5px;}.rpwe-alignleft{display:inline;float:left;}.rpwe-alignright{display:inline;float:right;}.rpwe-aligncenter{display:block;margin-left: auto;margin-right: auto;}.rpwe-clearfix:before,.rpwe-clearfix:after{content:"";display:table !important;}.rpwe-clearfix:after{clear:both;}.rpwe-clearfix{zoom:1;}
</style>
	<li id="rpwe_widget-6" class="widget rpwe_widget recent-posts-extended"><h2 class="widgettitle">Education</h2>
<div  class="rpwe-block "><ul class="rpwe-ul"><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://www.orangeleader.com/2020/10/13/exxonmobil-pipeline-company-donates-to-ohs/" title="Permalink to ExxonMobil Pipeline company Donates to OHS" rel="bookmark">ExxonMobil Pipeline company Donates to OHS</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://www.orangeleader.com/2020/10/13/classes-resume-at-tekoa-academy/" title="Permalink to Classes Resume at Tekoa Academy" rel="bookmark">Classes Resume at Tekoa Academy</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://www.orangeleader.com/2020/10/08/tekoa-academy-goes-all-virtual-on-friday/" title="Permalink to Tekoa Academy Goes All Virtual on Friday" rel="bookmark">Tekoa Academy Goes All Virtual on Friday</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://www.orangeleader.com/2020/10/06/orangefield-homecoming-court-2020/" title="Permalink to Orangefield Homecoming Court 2020" rel="bookmark">Orangefield Homecoming Court 2020</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://www.orangeleader.com/2020/10/05/lsco-anglers-headed-to-national-championship/" title="Permalink to LSCO Anglers headed to National Championship" rel="bookmark">LSCO Anglers headed to National Championship</a></h3></li></ul></div><!-- Generated by http://wordpress.org/plugins/recent-posts-widget-extended/ --></li>
<style>
.rpwe-block ul{list-style:none!important;margin-left:0!important;padding-left:0!important;}.rpwe-block li{border-bottom:1px solid #eee;margin-bottom:10px;padding-bottom:10px;list-style-type: none;}.rpwe-block a{display:inline!important;text-decoration:none;}.rpwe-block h3{background:none!important;clear:none;margin-bottom:0!important;margin-top:0!important;font-weight:400;font-size:12px!important;line-height:1.5em;}.rpwe-thumb{border:1px solid #EEE!important;box-shadow:none!important;margin:2px 10px 2px 0;padding:3px!important;}.rpwe-summary{font-size:12px;}.rpwe-time{color:#bbb;font-size:11px;}.rpwe-comment{color:#bbb;font-size:11px;padding-left:5px;}.rpwe-alignleft{display:inline;float:left;}.rpwe-alignright{display:inline;float:right;}.rpwe-aligncenter{display:block;margin-left: auto;margin-right: auto;}.rpwe-clearfix:before,.rpwe-clearfix:after{content:"";display:table !important;}.rpwe-clearfix:after{clear:both;}.rpwe-clearfix{zoom:1;}
</style>
	<li id="rpwe_widget-7" class="widget rpwe_widget recent-posts-extended"><h2 class="widgettitle">Business</h2>
<div  class="rpwe-block "><ul class="rpwe-ul"><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://www.orangeleader.com/2020/10/16/welcome-ncj-lawn-service/" title="Permalink to Welcome NCJ Lawn Service" rel="bookmark">Welcome NCJ Lawn Service</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://www.orangeleader.com/2020/10/16/welcome-donnas-new-begininz-academy/" title="Permalink to Welcome Donna&#8217;s New Begininz Academy" rel="bookmark">Welcome Donna&#8217;s New Begininz Academy</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://www.orangeleader.com/2020/10/16/oc-bars-approved-to-reopen-at-50-percent/" title="Permalink to OC bars approved to reopen at 50-percent" rel="bookmark">OC bars approved to reopen at 50-percent</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://www.orangeleader.com/2020/10/14/new-restaurant-opens-in-bridge-city/" title="Permalink to New restaurant opens in Bridge City" rel="bookmark">New restaurant opens in Bridge City</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://www.orangeleader.com/2020/10/10/covid-19-pandemic-affects-local-economy/" title="Permalink to COVID-19 pandemic affects local economy" rel="bookmark">COVID-19 pandemic affects local economy</a></h3></li></ul></div><!-- Generated by http://wordpress.org/plugins/recent-posts-widget-extended/ --></li>
	<li>
		<div class="story_list widget">
			<ul>
							</ul>
		</div>
	</li>
		<li>
		<div class="ad">
			<div id='div-gpt-ad-bigblock-3'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-bigblock-3'); });
  </script>
</div>		</div>
	</li>

	<style>
.rpwe-block ul{list-style:none!important;margin-left:0!important;padding-left:0!important;}.rpwe-block li{border-bottom:1px solid #eee;margin-bottom:10px;padding-bottom:10px;list-style-type: none;}.rpwe-block a{display:inline!important;text-decoration:none;}.rpwe-block h3{background:none!important;clear:none;margin-bottom:0!important;margin-top:0!important;font-weight:400;font-size:12px!important;line-height:1.5em;}.rpwe-thumb{border:1px solid #EEE!important;box-shadow:none!important;margin:2px 10px 2px 0;padding:3px!important;}.rpwe-summary{font-size:12px;}.rpwe-time{color:#bbb;font-size:11px;}.rpwe-comment{color:#bbb;font-size:11px;padding-left:5px;}.rpwe-alignleft{display:inline;float:left;}.rpwe-alignright{display:inline;float:right;}.rpwe-aligncenter{display:block;margin-left: auto;margin-right: auto;}.rpwe-clearfix:before,.rpwe-clearfix:after{content:"";display:table !important;}.rpwe-clearfix:after{clear:both;}.rpwe-clearfix{zoom:1;}
</style>
	<li id="rpwe_widget-8" class="widget rpwe_widget recent-posts-extended"><h2 class="widgettitle">Entertainment</h2>
<div  class="rpwe-block "><ul class="rpwe-ul"><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://www.orangeleader.com/2020/10/15/fabulous-equinox-orchestra-hurricane-recovery-benefit-concert-postponed/" title="Permalink to Fabulous Equinox Orchestra Hurricane Recovery Benefit Concert Postponed" rel="bookmark">Fabulous Equinox Orchestra Hurricane Recovery Benefit Concert Postponed</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://www.orangeleader.com/2020/10/08/video-the-fabulous-equinox-orchestra-to-host-benefit-jazz-concert-for-hurricane-laura-recovery/" title="Permalink to VIDEO: Fabulous Equinox Orchestra to host benefit Jazz concert" rel="bookmark">VIDEO: Fabulous Equinox Orchestra to host benefit Jazz concert</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://www.orangeleader.com/2020/09/09/the-venue-at-belle-oaks-hosts-open-house/" title="Permalink to The Venue at Belle Oaks hosts Open House" rel="bookmark">The Venue at Belle Oaks hosts Open House</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://www.orangeleader.com/2020/08/05/local-in-film/" title="Permalink to Local in film" rel="bookmark">Local in film</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://www.orangeleader.com/2020/08/05/op-ed-save-our-stages/" title="Permalink to OP-Ed: Save our stages" rel="bookmark">OP-Ed: Save our stages</a></h3></li></ul></div><!-- Generated by http://wordpress.org/plugins/recent-posts-widget-extended/ --></li>
<style>
.rpwe-block ul{list-style:none!important;margin-left:0!important;padding-left:0!important;}.rpwe-block li{border-bottom:1px solid #eee;margin-bottom:10px;padding-bottom:10px;list-style-type: none;}.rpwe-block a{display:inline!important;text-decoration:none;}.rpwe-block h3{background:none!important;clear:none;margin-bottom:0!important;margin-top:0!important;font-weight:400;font-size:12px!important;line-height:1.5em;}.rpwe-thumb{border:1px solid #EEE!important;box-shadow:none!important;margin:2px 10px 2px 0;padding:3px!important;}.rpwe-summary{font-size:12px;}.rpwe-time{color:#bbb;font-size:11px;}.rpwe-comment{color:#bbb;font-size:11px;padding-left:5px;}.rpwe-alignleft{display:inline;float:left;}.rpwe-alignright{display:inline;float:right;}.rpwe-aligncenter{display:block;margin-left: auto;margin-right: auto;}.rpwe-clearfix:before,.rpwe-clearfix:after{content:"";display:table !important;}.rpwe-clearfix:after{clear:both;}.rpwe-clearfix{zoom:1;}
</style>
	<li id="rpwe_widget-9" class="widget rpwe_widget recent-posts-extended"><h2 class="widgettitle">Lifestyle</h2>
<div  class="rpwe-block "><ul class="rpwe-ul"><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://www.orangeleader.com/2020/10/18/faith-praises-for-his-blessings-and-provision/" title="Permalink to FAITH: Praises for His blessings and provision" rel="bookmark">FAITH: Praises for His blessings and provision</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://www.orangeleader.com/2020/10/17/faith-understanding-earths-final-conflict/" title="Permalink to FAITH: Understanding Earth’s final conflict" rel="bookmark">FAITH: Understanding Earth’s final conflict</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://www.orangeleader.com/2020/10/17/and-now-you-know-eighty-years-ago-in-orange-on-october-17-1940/" title="Permalink to And Now You Know: Eighty years ago in Orange on October 17, 1940" rel="bookmark">And Now You Know: Eighty years ago in Orange on October 17, 1940</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://www.orangeleader.com/2020/10/17/master-gardeners-tips-for-cleaning-your-garden-after-a-storm/" title="Permalink to Master Gardeners: Tips for cleaning your garden after a storm" rel="bookmark">Master Gardeners: Tips for cleaning your garden after a storm</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://www.orangeleader.com/2020/10/17/god-and-country-rally-set-for-oct-24/" title="Permalink to God and Country Rally set for Oct. 24" rel="bookmark">God and Country Rally set for Oct. 24</a></h3></li></ul></div><!-- Generated by http://wordpress.org/plugins/recent-posts-widget-extended/ --></li>
<li id="custom_html-2" class="widget_text widget widget_custom_html"><h2 class="widgettitle">Calendar of Events</h2>
<div class="textwidget custom-html-widget">		<div id="calendarMask">
			<iframe src="https://www.google.com/calendar/embed?showTitle=0&amp;showNav=0&amp;showDate=0&amp;showPrint=0&amp;showTabs=0&amp;showCalendars=0&amp;showTz=0&amp;mode=AGENDA&amp;height=400&amp;wkst=1&amp;bgcolor=%23FFFFFF&amp;src=orangeleader.com_h3de9ii7kj8qh12c7mnajn6qkc%40group.calendar.google.com&amp;color=%230F4B38&amp;ctz=America%2FChicago" style=" border-width:0 " width="300" height="400" frameborder="0" scrolling="no"></iframe>		</div>
		<center><a href="/services/submit-an-event/">Submit an event to the Calendar</a></center>
</div></li>

	<li>
		<div class="ad">
			<div id='div-gpt-ad-halfpage-1'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-halfpage-1'); });
  </script>
</div>		</div>
	</li>
  
</ul>							</div>

              
	<!-- SCREENSHIFT -->
<div id='div-gpt-ad-screenshift'>
<script type='text/javascript'>
jQuery(window).load(function() { // These functions get called when everything has loaded
	if (!loggedin) {
    //console.log('========== BNI v10b not logged in ==========');
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-screenshift'); });
  } else { 
    console.log('========== BNI v10b logged in ==========');
  }
});
</script>
</div>
 <div class="clearfix"></div>
<div class="ad">
</div>
		<div class="ad">
			<!-- ROS_728x90_Bottom -->		</div>
					</div>
					<div id="footer" class="clearfix">
						<div id="footSections" class="col">
														<h4>Sections</h4>
							<ol class="siteMap">
								<li><a href="https://www.orangeleader.com" rel="bookmark"><span>Home</span></a></li>
								<li><a href="https://www.orangeleader.com/category/news/"  title="" rel="bookmark"><span>News</span></a></li>
								<li><a href="https://www.orangeleader.com/category/sports/" title="" rel="bookmark"><span>Sports</span></a></li>
								<li><a href="https://www.orangeleader.com/category/opinion/" title="" rel="bookmark"><span>Opinion</span></a></li>
								<li><a href="https://www.orangeleader.com/category/lifestyle/" title="" rel="bookmark"><span>Lifestyle</span></a></li>
								<li><a href="https://www.orangeleader.com/category/health/" title="" rel="bookmark"><span>Health</span></a></li>
								<li><a href="https://marketplace.orangeleader.com/adhunter/orangecounty" title="" rel="bookmark"><span>Classifieds</span></a></li>
							</ol>
						</div>


						<div id="footServices" class="col">
														<h4>Services</h4>
							<ol class="siteMap">
								<li><a href="https://www.orangeleader.com/services/about-us/" title="" rel="bookmark">About Us</a></li>
								<li><a href="" title="" rel="nofollow">Subscribe</a></li>
								<li><a href="https://www.orangeleader.com/services/policies/" title="" rel="bookmark">Policies</a></li>
								<li><a href="https://www.orangeleader.com/services/policies/#termsofuse" title="" rel="nofollow">Terms of use</a></li>
								<li><a href="https://www.orangeleader.com/services/submit-a-news-tip/" title="" rel="nofollow">Submit a news tip</a></li>
								<li><a href="https://www.orangeleader.com/services/submit-a-photo/" title="" rel="nofollow">Submit a photo</a></li>
				
								
															</ol>
						</div>


						<div id="footCopyright" class="col">
														<h4>Copyright</h4>
							<ol>
								<li>&copy; 2020, Orange Leader</li>
							</ol>
						</div>

					</div>
				</div>


				        <script src="https://www.orangeleader.com/wp-content/themes/2016-bni/media/js/vendor/jquery.bxslider/jquery.bxslider.min.js"></script>
        <script src="https://www.orangeleader.com/wp-content/themes/2016-bni/media/js/vendor/jquery.contentcarousel.js"></script>
        <script src="https://www.orangeleader.com/wp-content/themes/2016-bni/media/js/vendor/jquery.easing.1.3.js"></script>
				<script src="https://www.orangeleader.com/wp-content/themes/2016-bni/media/js/vendor/jquery.timeago.js"></script>
        <script src="https://www.orangeleader.com/wp-content/themes/2016-bni/media/js/plugins.js?1600317682"></script>
        <script src="https://www.orangeleader.com/wp-content/themes/2016-bni/media/js/main.js?1600317682"></script>

        
				
<script type="text/javascript">tb_pathToImage = "https://www.orangeleader.com/wp-includes/js/thickbox/loadingAnimation.gif";tb_closeImage = "https://www.orangeleader.com/wp-includes/js/thickbox/tb-close.png";</script>
<script>
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"https:\/\/www.orangeleader.com\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};
</script>
<script>
var pollsL10n = {"ajax_url":"https:\/\/www.orangeleader.com\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};
</script>
<script type='text/javascript' src='https://www.orangeleader.com/_static/??-eJx1jkEOwjAMBD9E6kZIhQviL01dcEgcK3ZUnk+oBOLCxfKud1aGTRxxSG1BhahgdwqPuTy/yxD1AD0UChuygaR2I1bIaLUwmpNaVkrohIK1iu+SLOLWugPLP75bUlJS2KeL+gn+ftMl5hmXIRP3+zVf/DSOR3+azj6+ABGfRMA='></script>
<script type='text/javascript' src='https://stats.wp.com/e-202042.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:9.0.2',blog:'175848598',post:'65963',tz:'-5',srv:'www.orangeleader.com'} ]);
	_stq.push([ 'clickTrackerInit', '175848598', '65963' ]);
</script>
				</div><!-- END undertone -->
        				<script id="dsq-count-scr" src="//orangeleader.disqus.com/count.js" async></script>
            </body>
</html>